MediaWiki 失敗的升級

原本打算從 mediawiki 1.4.0 升到 1.5.x 版 ,一直失敗,會出現資料庫錯誤或找不到資料的情形,也找不到原因在哪裏,猜想是 database 的 scheme 在升級時不能判斷正確的編碼所致。空閒時間不多,所以決定還是用 1.4.x 系列的第 13 版 (1.4.13) , 1.5.5 和 1.4.13 是幾乎同時間出來的版本,我在想大概是 mediawiki 的官方為了體貼我們這些跳不到新版本的人而出的吧。有人成功從 1.4.x 升級到 1.5.x 的嗎?

再抱怨一下, mediawiki 的安裝文件寫得真差,安裝的步驟也不像其他架站系統簡易,有些還要動到 command line……

另外也把主機移至新的虛擬主機,新主機不支援漂亮的網址 (也就是網址不包含 index? 這些字),查出原因是 php 採用 cgi 模式在運作,所以不能支援,所以在安裝時,要看清楚,若是像我的主機的環境的話,就不要費心再去改 config 檔了。舊主機有支援漂亮的網址,所以 google cache 過的網頁記錄要重新來過了。

再來是廣告時間:

若您對英語教學有興趣,請連至 http://www.tesol-taiwan.org/ ,(台灣英語教學圍紀),有些有趣的東西可以看,也歡迎英語教師去那裏寫寫,想利用那個圍紀作教學用途的老師們也可以帶學生去寫寫看,不用特別經過該 wiki 管理員(也就是我)的同意。 🙂

廣告

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com Logo

您的留言將使用 WordPress.com 帳號。 登出 / 變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 / 變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 / 變更 )

Google+ photo

您的留言將使用 Google+ 帳號。 登出 / 變更 )

連結到 %s